Experiencing partial outage

Billing Portal Maintenance

Completed
Scheduled for 25/06/2022 at 7:05:00 PM – 8:05:00 PM

Affects

Public Services
Billing Portal
Updates
  • Completed
    25/06/2022 at 8:05:00 PM
    Completed
    25/06/2022 at 8:05:00 PM

    Maintenance has completed successfully.

  • In progress
    25/06/2022 at 7:05:00 PM
    In progress
    25/06/2022 at 7:05:00 PM

    Maintenance is now in progress.

  • Planned
    25/06/2022 at 7:05:00 PM
    Planned
    25/06/2022 at 7:05:00 PM

    We are planning for scheduled maintenance during the time mentioned in this maintenance notice.